2003 LS V8 charcoal grey and 2006 LS V8 black

  • having difficulty uploading pics .. file size.. photo-2.JPG IMG_20170725_184637_hdr_edit1_edit-EFFECTS.jpg .anyway member since late 2012 ..Managed to finally upload pictures ....the black LS is a recent acquisition very well kept by previous owner , was in immaculate condition, had work done, new radiator, rear brake discs, fully loaded american version LS and however did have a mysterious coolant leak but never would overheat. 03 charcoal grey LS Ive owned from 2012 at 146 KM and have had all work done at the local ford dealership until late last year when I had to deal with a degas bottle leak( I have had all oil changes and coolant flush including transmission flush at said dealership and had to contend with 3 oil leaks after an oil change and a coolant leak after a thermostat and housing replacement).I did not do a complete cooling system overhaul and chose instead to replace the 3 piece plastic thermostat housing /coolant outlet pipe and the most challenging 9N499 coolant outlet on both.No issues 2 months in ,all bolts and seals were obviously new , I did however break a bolt for the 9N499 coolant outlet at rear right side for the charcoal grey LS( I do have the shop manuals and a torque wrench purchase is in my amazon wish list..lol;-).) but as expected the 8A504 coolant outlet has enough bolt back pressure to keep the 9N499 seated and leak proof(maybe).... (at +200KM I did the charcoal grey LS first as I had no faith in my work) and should a coolant leak spring up from the missing bolt location I am resigned to a parting out and maybe I can get a set of angel eye project headlights ....I find that the one hose at the back of the fire wall for the degas was more challenging than the 3 piece coolant plastic replacement, refilling and bleeding the system went as planned for both, no coolant leaks on my driveway and having to carry coolant to refill the degas for both periodically, no radiator fan going crazy, in short emboldened to see what these cars throw at me next. I did break a fuel pressure sensor on the black LS while removing the EGR but all in was happy with my first attempt at taking care of service. Did a headlight restore on the 03 and did a key fob shell refresh too for both. I had to pull the 06 off the battery tender when the 03 with my winter set up 16 inch winter tires experienced a massive leak and the obligatory overheat..... IMG_20180322_184006.jpg 1.jpg 2.jpg 3.jpg 4.jpg 5.jpg 6.jpg 7.jpg 8.jpg 9.jpg 10.jpg 11.jpg 12.jpg 13.jpg 14.jpg 15.jpg 16.jpg 17.jpg 18.jpg 19.jpg 20.jpg 21.jpg 22.jpg 23.jpg 24.jpg 25.jpg 26.jpg 28.jpg 29.jpg 30.jpg 31.jpg 274.jpg 32.jpg photo-2.JPG IMG_20170725_184637_hdr_edit1_edit-EFFECTS.jpg am fully resigned to a parting out situation)
EJay58 and Svets96 like this.

User Comments

To post comments, simply sign up and become a member!
  1. EJay58
    I have the same LS V8 in black on black driving daily on the German Autobahns. I really enjoy the looks I get when passing Mercs and Beamers as they're trying to figure what European make I'm driving. By the way, in case you're wondering, she governs out at 133mph. But, if your suspension is tight (upgraded mine to Moog), aligned and balanced, and the tires are fresh, she glides along the highway like on ice skates. Take care of it well. Nice photos.
      Nemesis Prime likes this.
    1. Nemesis Prime
      uploaded a few pictures of recent work thanks for the comment, keep the faith these are beautiful cars sad there arent enough in europe ....or canada i go months sometimes with no sightings..
      Nemesis Prime, May 5, 2018