So new tranny in but ?????'s

01LSV8TX

LVC Member
Joined
Nov 22, 2008
Messages
49
Reaction score
0
Location
Funky Town
So when I am driving the car for a bit on the HWY on my 60mi commute, and I come to a stop at a light after exiting, the car acts as if is in neutral.... Anybody?

***The tranny has been the car for 2 weeks, bought it from a guy here on the forums that claimed it had a 5k old rebuild from amco. Runs fine 98% of the time which leads me to believe that it is not low on fluid, I have not had the fluid checked since the install since it is a pain to do...
 
Last edited:

01LSV8TX

LVC Member
Joined
Nov 22, 2008
Messages
49
Reaction score
0
Location
Funky Town
It's not to that point yet and I dont want it to. I just want the damn car to run...Spent 4k in the last couple of months trying to get it right...
 

1bad4.6l

Dedicated LVC Member
Joined
Nov 7, 2007
Messages
2,603
Reaction score
2
Location
wyandotte
Before callin someone out have the shop that installed it check there work and the fluid, and also if it is bunk tell the guy you got it from and get the paperwork from the amco. amco is everywhere and will back anothers warranty just dont tell them youre not the one who paid for the rebuild. Its not like they will have to prove you are you. But you will probably need the old receipt. Word to the wise around here amco sucks and will rip you off bad. :D :D :D :D tell them you moved and thats why youre not goin back to that shop.
 

01LSV8TX

LVC Member
Joined
Nov 22, 2008
Messages
49
Reaction score
0
Location
Funky Town
I think ammco fixing it is a stretch... It's not worth taking it to the shop to check, I can check it, just probing for thoughts.
 

386Motoring

Active LVC Member
Joined
Jun 9, 2009
Messages
168
Reaction score
0
Location
Daytona Beach, Florida
I just meant to call him out, not cause its his fault. Like dude up there said. The shop could have done something wrong. Also your car could have other components of the trans system out of order. Having a trans just rebuilt is a bold statement.... Why would a trans only have 5k on it after a rebuild? weird huh
 

drag214

Well-Known LVC Member
Joined
Apr 30, 2009
Messages
366
Reaction score
5
Location
California
Check the fluid. Like you said, it’s a pain to do. Maybe the person doing the install was thinking the same thing. Or maybe they thought a little extra fluid wouldn't cause any damage. If you didn't do the work, you should inspect the job to the best of your abilities. Unless it's going to void a warrantee
 

drag214

Well-Known LVC Member
Joined
Apr 30, 2009
Messages
366
Reaction score
5
Location
California
I think ammco fixing it is a stretch... It's not worth taking it to the shop to check, I can check it, just probing for thoughts.

:eek: That's a long laundry list you got there.

I put a lot of work into mi LS too. It's got 180,000 +miles and counting. It took me 18 days to get it running.Then another month to get it to pass Cali smog.
 

Members online

No members online now.
Top