Please help no power, among other issues.

Lincoln LS

  1. tank

    tank LVC Member

    Messages:
    19
    Likes Received:
    2
    Joined:
    Mar 15, 2016
    Location:
    landover
    I recently purchased a 04 ls v8 sport with a hard running issue it starts and runs no problem but is in ETC failsafe mode; No power from the throttle at all in any gear. It starts off high around 2k then kicks down 500rpm till it settles around 750. Ran the CEL got 12 codes
    P0102,p0108,p0113,p0122,p0223,p0406,p2100,p2104,p2107,p2110,2111,p2112,p0122,p0223, and p20104. It runs rough, the throttle body revs when pushed psychically(well kind of it will rev but slowly then cut off by the engine or pcm.i also have pictures of the TB), otherwise when usin the pedal it does literally nothing. I also did a swap of the coils from cylinders 1&4 as a shot at it being a coil problem. Also it runs a little smoother with the throttle position sensor unplugged. Sorry for the rant.

    81B9CAEB-711C-4431-A924-CEA3D17D096C.jpeg

    AA729F9E-A078-4E6A-B7C6-59E74D9663A5.jpeg
     
    Last edited: Sep 15, 2018
  2. tank

    tank LVC Member

    Messages:
    19
    Likes Received:
    2
    Joined:
    Mar 15, 2016
    Location:
    landover
    Also it would appear there is a leak I’m not sure if it is a rip in the weather stripping that leaks by the door or the hole in the stripping around the windshield, or if the sunroof is clogged. Then there is the lack of ac or heat ‍♂️And a leak I assume it the secondary pump but I’m not sure.
     
  3. joegr

    joegr Dedicated LVC Member

    Messages:
    18,477
    Likes Received:
    2773
    Joined:
    Dec 10, 2005
    Location:
    Gulfport
    Wow, that looks terrible. You need to find and fix the coolant leaks first. I would not be surprised if the throttle body actually has failed.
    You have a problem with the MAF or the wiring to it.
    You have a problem with the EGR assembly or the wiring or the vacuum tubing to it.
    You have problems with the TPS and the throttle body.

    I'm guessing it's corroded parts and wiring.
     
    • Like Like x 1
    • Agree Agree x 1
    • tank

      tank LVC Member

      Messages:
      19
      Likes Received:
      2
      Joined:
      Mar 15, 2016
      Location:
      landover
      I figured it could all be bad, for some reason or another the car had been sitting at a dealership for 3 years.
       
    • lincoln_zero

      lincoln_zero Dedicated LVC Member

      Messages:
      598
      Likes Received:
      33
      Joined:
      Aug 10, 2012
      Location:
      ICE COLD CANADA
      So the dealership parked it and never drove it? That is bizarre.
       
    • tank

      tank LVC Member

      Messages:
      19
      Likes Received:
      2
      Joined:
      Mar 15, 2016
      Location:
      landover
      Yes, I found it odd too when I went to see it from the outside the car is clean the engine is rough as you can see in the pic but it has 120k on the clock and I got it for $200. For now I’m about to buy a maf, throttle body, cops, plugs, fuel filter, air filter, and a cabin filter. Then figure out if I need a diverter valve or a secondary pump because I can’t get heat or ac.
       
    • joegr

      joegr Dedicated LVC Member

      Messages:
      18,477
      Likes Received:
      2773
      Joined:
      Dec 10, 2005
      Location:
      Gulfport
      Wow, hard to complain for $200.
       
      • Like Like x 1
      • tank

        tank LVC Member

        Messages:
        19
        Likes Received:
        2
        Joined:
        Mar 15, 2016
        Location:
        landover
        I know right I found it on Craigslist and said if it has an engine tranny and decent body I’ll take it no matter the problem. By the looks of it I’ll be a grand or so in it but that’s still cheaper than a well put together example with similar mileage.
         
      • tank

        tank LVC Member

        Messages:
        19
        Likes Received:
        2
        Joined:
        Mar 15, 2016
        Location:
        landover
        Well I got a new throttlebody in yesterday finally a few moments between the torrential downpours out
        Here to throw it on. Wouldn’t you know it I now have throttle response, now to get this idle together I need to take it around the corner to run the codes. I’ll post my finding I bought some coils and plus anyway but after much research think I’ll keep the coils for a rainy day and save up for motorcraft ones.
         
        • Like Like x 2
        • tank

          tank LVC Member

          Messages:
          19
          Likes Received:
          2
          Joined:
          Mar 15, 2016
          Location:
          landover
          Well a week or so of mini trips and now I’ve got a coolant leak and a bad ball joints(3 years of inactivity I’m surprised they held up to any driving). Side lined until I get paid.
           
        • 04_Sport_LS

          04_Sport_LS Dedicated LVC Member

          Messages:
          1,920
          Likes Received:
          178
          Joined:
          Jun 12, 2012
          Location:
          Somewhere around Lake Erie
          I hope the FIRST thing you did is change the oil and filter. Coolant leaks starting to pop up now? There goes a grand for a full system rebuild. And do yourself a favor when it comes to the cooling system... buy only Motorcraft parts.
           
          • Like Like x 1

          Share This Page