Mark VIII Neglect

Warden

Dedicated LVC Member
Joined
Jul 21, 2005
Messages
681
Reaction score
7
Location
Bellingham
Here is a pic of my verts ass in the Shrine

20150914_155357.jpg
 

Warden

Dedicated LVC Member
Joined
Jul 21, 2005
Messages
681
Reaction score
7
Location
Bellingham
But that's it. That's all I am going to be sharing here is 5 year old photos.
 

BigredLsc

Active LVC Member
Joined
Dec 23, 2019
Messages
121
Reaction score
5
Location
Orange ca
I will do my best to provide updates, and photos of my progression. I will post in other peoples threads that have nothing to do with my cars so everyone can be happy.
Did you message bombed the F**k outta this post gezus buddy relax lol
 

Warden

Dedicated LVC Member
Joined
Jul 21, 2005
Messages
681
Reaction score
7
Location
Bellingham
First step of Hyde's exhaust has started. Just came back from the shop to have it designed, and some measurements for the SS flanges at the manifolds. The whole system, including hangers and weld wire, will be SS (4 series tube, 3 series hangers and wire). On Jeremi's recommendation it will be 2.5" SS series from the manifolds to (2) new cats into a 2 into 1 resonator/muffler. 3" from the resonator to the rear diff where it will split into (2)2.5" to some new black chrome tips. Quote of 2k with the cats. This picture is from Jeremi when he finished the install in 2012, but it looks exactly the same today, but the cats are falling apart. This is not the convertible above.

244.jpg


MYHYDE at Larz Anderson.jpg
 

BigredLsc

Active LVC Member
Joined
Dec 23, 2019
Messages
121
Reaction score
5
Location
Orange ca
Does the rear end compress at all
Will the rear bearing/ hub if it’s bad affect the front alignment ? My bushing and suspension seem fine 97 mark , and the front driver tire just keeps going out ... smh 2nd tire in 3 months ,3723 miles total driven in the 3 months(alignment was done 8 months ago but seems to be wearing off)

0DFA2F5E-0D8A-4C20-9823-2F6EA7CF9226.jpeg
 

xtriggerman

Well-Known LVC Member
Joined
Jan 7, 2019
Messages
243
Reaction score
80
Location
TN
"Seems" is not a very good description. It is either good or bad. Anything in between needs replacing. when I bought my 97 with 67K miles on it the front end was totally shot. The only way to test those components IMO is get the hub assembly in the air, and at least disconnect the sway bar, then the upper ball joint. Then you can REALLY see whats going on. From what I'v read, these wheel joints go bad pretty quickly. So if you have very many miles on them, chances are they are in fact loose.

On another note, That convertible posted by Warden is pretty interesting. Wonder how much extra steel & welding went into the frame of that to keep the doors from pinching shut from a WOT over some rougher road surface. Normally I would think a 3700 pound 2 door una body is a poor candidate for a conversion... but hey anything may be possible with a s**t load of mods!
 

BigredLsc

Active LVC Member
Joined
Dec 23, 2019
Messages
121
Reaction score
5
Location
Orange ca
"Seems" is not a very good description. It is either good or bad. Anything in between needs replacing. when I bought my 97 with 67K miles on it the front end was totally shot. The only way to test those components IMO is get the hub assembly in the air, and at least disconnect the sway bar, then the upper ball joint. Then you can REALLY see whats going on. From what I'v read, these wheel joints go bad pretty quickly. So if you have very many miles on them, chances are they are in fact loose.

On another note, That convertible posted by Warden is pretty interesting. Wonder how much extra steel & welding went into the frame of that to keep the doors from pinching shut from a WOT over some rougher road surface. Normally I would think a 3700 pound 2 door una body is a poor candidate for a conversion... but hey anything may be possible with a s**t load of mods!
Yeah man ur totally right the bushings in the joints are shot the fudge out .. on another note today now my temp needle has been spiking up and down in 102 degree weather (good ol Cali) I have a griffin radiator 4 row I believe and new water pump new resivor tank and all new hoses.. system is burped.. but only while on the gas and A.c on “automatic” setting the needle will rise above normal temp , hoping it’s the thermostat which I haven’t changed ... problem after problem .. then it wouldn’t be a stinkin Lincoln lol
 

Members online

Top