Electrical issues - 02V8

Lincoln LS

  1. Cicerojonezz

    Cicerojonezz New LVC Member

    Messages:
    1
    Likes Received:
    0
    Joined:
    Dec 15, 2017
    Location:
    Dickson city PA
    Hey guys I have an 02 V8, love it. I'm having some electrical issues while I'm driving, the headlights/cluster lights will dim and she acts like she wants to stall out, but then everything will go back to normal. It's been happening a lot more as it gets colder out (north east). I tried searching the forums and Google but no luck. If anyone has had this problem before let me know.


    I'm also getting some hesitation from her at higher speeds (50+) when I try to accelerate. Coils maybe?

    Also getting some gas smell inside the car when I first start her up, I haven't noticed any leaks under the car so I'm not sure, I'm not sure what kind of gas was used before I bought her (2 months ago) but I've been using 91/93.

    Any help or where I should point my attention is greatly appreciated, thanks guys.
     
    Last edited: Dec 15, 2017
  2. joegr

    joegr Dedicated LVC Member

    Messages:
    17,518
    Likes Received:
    2494
    Joined:
    Dec 10, 2005
    Location:
    Gulfport
    Your alternator is probably failing (could be loose wiring instead). Unfortunately, the 1st gen is really picky about the alternator. Your only safe bet is to get a Motorcraft one.

    This could be lots of things, including marginal coils (for both symptoms). Coils are a known weakness of this car. If you can afford it, it would be good to replace all eight COPs (use Motorcraft) and all eight spark plugs (NGK is good, Bosch is bad - be sure to set or verify the gap at 1.0mm).
     
  3. AmsterDutch

    AmsterDutch Well-Known LVC Member

    Messages:
    382
    Likes Received:
    52
    Joined:
    Jul 9, 2017
    Location:
    Minnesota
    I agree NGK is a great plug for the LS my Lincoln has been purring like a kitten with these plugs
     

Share This Page