94 Mark VIII electrical gremlin at my wits end

Lincoln Mark VIII

  1. BC Mark VIII

    BC Mark VIII LVC Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 13, 2016
    Location:
    White Rock,Canada
    really need help here folks.when my car was stored outside last winter(very damp,no cover) I went out to start it(done on monthly basis) and battery was dead..charged battery,reconnected battery and headlights,tail lights,dash lights and center dash lights all came on(NOT including message center)..all switches are off,no key in ignition.pulled light switches and checked for continuity function,both working proper on/off positions.checked relays under hood for proper function,both ok..sometimes lights come on right away,sometimes takes anywhere from a few minutes to a few hours but both relays are getting powered up for some reason.have to pull 40 amp maxifuse to stop from happening...since then,I have had added intermittent problems with power windows,power locks,dash turn signal indicators (but not the turn signals themselves,they function properly)...what is the common denominator??? this is a Canadian model if that makes a difference..does the first gen have a body control module?I've been told no..I need to get the tranny rebuilt but unsure whether to do so until I figure out what is causing my electrical problems..PLEASE HELP..any questions I will give whatever info I can...Thankyou
     
  2. BC Mark VIII

    BC Mark VIII LVC Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 13, 2016
    Location:
    White Rock,Canada
    update..while turning the interior light rotary switch on and off it was actuating the drivers door lock,then stopped
     
  3. 91 LSC SE

    91 LSC SE Well-Known LVC Member

    Messages:
    473
    Likes Received:
    30
    Joined:
    Sep 25, 2008
    Location:
    Canada
    I have seen a lot of strange things happen with a battery I thought was good and or corroded connections. Frist thing I would do is use a battery you know is good or have yours tested. I have a smart battery charger yet it has failed to recognize a defective battery.
    Second, ensure you have clean connections - you did say the M8 has been sitting in storage.
    I wouldn't use vaseline or anything else to stop corrosion. I used vaseline after cleaning my battery and cables as there was corrosion/build up and my M8 started doing all sorts of strange things. As soon as I removed the vasline from the cables/batteries, everything worked as intended.
     
  4. slowmkviii

    slowmkviii Dedicated LVC Member

    Messages:
    5,517
    Likes Received:
    366
    Joined:
    Sep 28, 2007
    Location:
    Elk River, MN
    Sounds like a short
    In gen 2s there's a bad spot for rubbing in the doors and will cut into the harness
     
  5. BC Mark VIII

    BC Mark VIII LVC Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 13, 2016
    Location:
    White Rock,Canada
    thanks for the reply guys...new battery and alternator..this is a gen 1.the door lock on the pass. side has quit working,will check wires on it...I wonder,,could the anti theft module cause this?
     
  6. Spree

    Spree Dedicated LVC Member

    Messages:
    1,162
    Likes Received:
    193
    Joined:
    May 26, 2012
    Location:
    Cambridge City, IN
    Any chance you passenger side floor is wet? Bunches of wires run under the carpet.
     
  7. BC Mark VIII

    BC Mark VIII LVC Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 13, 2016
    Location:
    White Rock,Canada
    yes,floor was very wet..thanks for the information..will check
     
  8. Spree

    Spree Dedicated LVC Member

    Messages:
    1,162
    Likes Received:
    193
    Joined:
    May 26, 2012
    Location:
    Cambridge City, IN
    Pull Carpet back and remove all water, dry the carpet and fix the wiper cowl.
     
  9. BC Mark VIII

    BC Mark VIII LVC Member

    Messages:
    26
    Likes Received:
    0
    Joined:
    Feb 13, 2016
    Location:
    White Rock,Canada
    floor has been dry for long time now..thinking it's more of a corrosion problem some where
     

Share This Page