2005 Lincoln Ls Ultimate aftermarket radio turns on but no sound

JustSomeNoob

LVC Member
Joined
Sep 10, 2022
Messages
10
Reaction score
2
Location
Canada
I dont know if Im in the right place, but I dont know what to do, its that kind of question radio turns on my no sound. My original radio didnt work and I brought it to mechanic whivh said radio head unit just not working. I bought eonon q04pro radio and a metra 5521 wiring harness for it which comes with power and some other cable. I spliced into power cable on metra and eonon and connected those. Only had 3 spare on eonon side which are back(for bavkup camera) and steering wheel controls 1 and 2. And thats basixally all needed tk be connected to have radio turn on. But it produces absolutely 0 sound Im suspecting its the sevong metra cable that was nowhere to be connected and jts the one that has that blue/white cable that everywhere I looked need to be connected for stereo to work... If someone ever had something like this, or just installed radio on their lincoln ls can you help and say what exacly u did, if I have to Ill buy another harness...
 

joegr

Dedicated LVC Member
Joined
Dec 10, 2005
Messages
21,160
Reaction score
2,107
Location
Gulfport
There is no off the shelf adapter to work with an LS that had the THX nav system.
Here is what you have to do:
 

JustSomeNoob

LVC Member
Joined
Sep 10, 2022
Messages
10
Reaction score
2
Location
Canada
There is no off the shelf adapter to work with an LS that had the THX nav system.
Here is what you have to do:
Thank you!
 

JustSomeNoob

LVC Member
Joined
Sep 10, 2022
Messages
10
Reaction score
2
Location
Canada
There is no off the shelf adapter to work with an LS that had the THX nav system.
Here is what you have to do:
Oh shoot thats a lot of stuff I literally do not undarstand ;-;
 

MarkEricRoth

Active LVC Member
Joined
Jun 15, 2018
Messages
81
Reaction score
30
Location
Philly
Mine is a '00 and I realize that '03's are different and I don't mean to insult anyone's intelligence here, but just in case it hasn't been discovered yet, have you tried the volume control on the back of the steering wheel (it looks like you know about it, but just in case)? I cursed ours for 5 years for its low volume, then I discovered the buttons on the back of the steering wheel.
 

JustSomeNoob

LVC Member
Joined
Sep 10, 2022
Messages
10
Reaction score
2
Location
Canada
Mine is a '00 and I realize that '03's are different and I don't mean to insult anyone's intelligence here, but just in case it hasn't been discovered yet, have you tried the volume control on the back of the steering wheel (it looks like you know about it, but just in case)? I cursed ours for 5 years for its low volume, then I discovered the buttons on the back of the steering wheel.
Haha thats not quite the problem, its just aftermarket radio install problems
 

Members online

Top