2002 Lincoln LS Owner Since 2004

Welcome Wagon Forum

  1. NorCalNorse

    NorCalNorse New LVC Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Dec 3, 2018
    Location:
    Moraga, California
    Hi Everyone, I am an owner of a 2002 Lincoln LS
    - going on 400k miles!!! Needless to say I am having issues popping up, LOL!

    Used to own a beautiful 1998 Lincoln Mark VIII from late 98 to 2004. Loved that car. Have to say it has the coolest interior for the Driver of any car I have ever owned. Felt Like i was in a cockpit of jet. Only reason I let her go was that I had huge issue with finding parts that were discontinued, and thats when I moved into my LS. Have enjoyed the LS, but not even close to the Mark VIII in total awesomeness!

    Anyways, hope to get some help with some strange happenings with my old LS.

    Regards to all!
    David
     
    Last edited: Dec 3, 2018
  2. goodpeople

    goodpeople New LVC Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    May 18, 2013
    Location:
    Tampa
    Welcome David!

    WOW 400K miles!!! Im only at 156K

    What issues have you had with your LS? Which 02 LS you own?

    V/R,
    GP
     
  3. NorCalNorse

    NorCalNorse New LVC Member

    Messages:
    8
    Likes Received:
    0
    Joined:
    Dec 3, 2018
    Location:
    Moraga, California
    I have the LS Sport V8. Picked it up in 2003 - it was a lease return with about 30k miles on it. Ive had the following issues which were all resolved, which seem to be common topics of interest on this site:
    *Engine Over Heating Issue (many topics on this one!)
    *Engine Mis Fire - very common and was always the ignition coils for my car
    *Leaking at the A frame Pillar
    *front end "clunking" noise - was a number of front end stuff over the years - ball joints, bushings, upper and lower control arms, struts, Tie rods, hub bearings - all typical stuff any car will deal with with age however.
    *Driver and passenger window falling - regulator issue. Once on each side.

    Currently Im dealing with the warning lights staying on - ABS / BRAKE / Adv. Trac lights along with the speedometer not working. They all went out at the same time. I started a topic for help recently on this site. Waiting on a device you plug in to read your error codes and get to the bottom of this issue.

    Other than the above - all has been good! LOL - The transmission has been solid, and the engine keeps on ticking! For 400k miles, not bad in my opinion. People are shocked (especially mechanics) that Im still running strong at 400k - I have always changed the oil at regular intervals, tune ups twice a year, and have only used Premium Gas! Maybe that has helped in the long run, I don't know.

    Hope you get to 400k as well! If i make 500k, I want Lincoln to put me in an add!! LOL!
     

Share This Page