Transmission problem? HArd shift then a drop in rpm's

91300zx

LVC Member
Joined
Mar 8, 2012
Messages
39
Reaction score
0
Location
RI
So my 04 LS V6 has started acting a little strange. When its shifting into first it shifts quick and hard I guess I would call it. It makes a clunking sound. Then when the rpm's are at about 2-3k they will drop slightly then pick back up. Seems to only happen when shifting into 1st as I haven't noticed it in any other gears. Any suggestions would be greatly appreciated. No codes or lights are on. Was going to start with a transmission flush since Im not sure if it ever had one. Coils and plugs were done about 7 or 8 months ago. Thanks for reading
 

joegr

Dedicated LVC Member
Joined
Dec 10, 2005
Messages
21,207
Reaction score
2,140
Location
Gulfport
Does it sometimes jerk into reverse?
Probably the solenoid assembly.
 

91300zx

LVC Member
Joined
Mar 8, 2012
Messages
39
Reaction score
0
Location
RI
Now that you mention it yes it does jerk in reverse. I'll put it in reverse and it will take a few seconds then finally go into reverse with a jerk. Is this something that someone with average mechanic skills can replace? Do I have to open up the tranny for this?
 

joegr

Dedicated LVC Member
Joined
Dec 10, 2005
Messages
21,207
Reaction score
2,140
Location
Gulfport
Yes, if they are able/willing to look up the specifics on the LS.
Yes, the solenoid assembly is inside the transmission. The pan has to be dropped, but the transmission remains in the car.
 

91300zx

LVC Member
Joined
Mar 8, 2012
Messages
39
Reaction score
0
Location
RI
Sorry for the dumb question but what kind of specifics. Thanks for the input joegr. Would you recommend all data for specifics?
 

1LoudLS

Dedicated LVC Member
Joined
Mar 31, 2008
Messages
9,895
Reaction score
356
Location
Ann Arbor
Sorry for the dumb question but what kind of specifics.
All kinds, specific instructions on how to do it, torque specifications for putting it back together, which fluid to fill it back up with...
 

Members online

Top