steering wheel telescopic function stuck


Dedicated LVC Member
Sep 25, 2008
Reaction score
Hi My tilt/telescopic wheel has always worked flawlessly. My M8 has been sitting for a bit as I source an ABS pump. now the tilt works fine but it doesn't move out. It seems like it went in too far as the signal switch is now tight against the dash. I found the following threads, I already tried pulling on it as I press the button for it to move outward, but it won't budge. When I use the switch to move it in, it can't go in any further but dash lights go dim, its seems to put a strain on the electrical system.

I also found this repair, though hoping I do not have to tear it all apart to get it back to the correct position:
It's really quite simple, any dingbat with a bench to work on and some simple tools can fix it. I know because I'm a dingbat and fixed two of them.

Remove kick panel, remove bolt from steering joint, disconnect the connectors to the steering column underneath, remove the 4-6 bolts holding the column. Give it a solid yank, take to work bench.
Make sure to not allow the wheel to spin independent of the column to avoid clock spring issues.

Now on the bench, you'll see lots of torque bolts holding the assemble together, loosen evenly and take your time.
Pull assembly apart, find the potentiometer, pull it, like 2 small torque screws. Remove the potentiometer, disassemble and clean all the old grease.
Usually I very carefully bend the little spring tabs to create a little more contact, them regrease with a good connector/electronic grease and reassemble and install.
I believe you do have to remove the rear motors, this way you can manually manipulate the column in and out in the case that you can't get to all the screws.
Also pull the battery cable... Obviously.

And if you aren't the athletic/skinny and flexible type, you may need to pull the driver seat.

It's been said before, but it's a great idea to disable all the auto moving items such as easy entry, memory and so on. To preserve the workings of your motors and functions.
Thanks! I thought I read on here some time ago, that if the lock spring breaks it lets the column travel to far inward and you have to replace that spring and that can be done with it in car?
I am unsure about the clockspring breaking.
But I can tell you I had the same issue you are currently having:
The easy entry function kept pulling the steering wheel in until it bottomed out on my blinker/multi switch. I pulled the whole column and found the potentiometer was just dirty. Cleaned/rebuilt it and been good every since.
It's been said before, but it's a great idea to disable all the auto moving items such as easy entry, memory and so on.
Unfortunately, the default seems to be, is to have them 'on', so whenever I pull the battery or remove the connection to save the battery for long periods of not driving the car, as soon as I reattach the battery, the friggin' computer thinks, 'Wow, I'm awake, I can move everything on my own now' again. That's what happened to me this time; after re-attaching the battery cable, as soon as I opened the driver's door, the steering wheel went into 'easy access' mode and pinned itself to the dash. Now it won't move. Since I'm the only one who drives it, I'll have to figure out a way to get it where I want it, and then disconnect the motors that move it.
yep that is what happened to my M8 too. The car was sitting due to trying to find a ABS pump.

Once I get my fixed and cleaned up it will not be an issue. For those who's M8's have sat for a while and you have never done any maintenance to your telescopic wheel, I recommend you enter through the passenger door to turn off easy entry first.

Members online