Recent content by Buzzy4542

  1. B

    Garage door opener on visor

    My garage door opener, located on the visor of my 2002 Lincoln Town Car, is failing (seems to be getting weaker). Is there a battery for this or is it somehow connected to the electrical system? Any/all suggestions welcome.
  2. B

    CTS Performance Coupe mufflers

    Does anybody know some "good sounding" mufflers I could install on my 2014 CTS Performance Coupe?
  3. B

    2004 Deville A/C Fan-blower

    My 2004 Deville "sometimes" will have the blower for the A/C start on "high", WHEN THE CAR IS LOCKED AND THE IGNITION IS OFF (key in my pocket). WHY does this do this? Anyone have any ideas? Might happen every 2-8 weeks and then runs the battery down. Does anyone know what fuse disconnects the...
  4. B

    Power Seat - 02 TC

    Does anyone have a power drivers seat (WITH MEMORY) for a 2002 Lincoln Town Car? I bought one, site unseen, and it does not have mamory and the plugs are different. Therefore, I am looking for another that is correct.:D
  5. B

    Remote door opener

    Yesterday, the "clicker" failed to unlock the doors and trunk. They work fine without the remoye. I changed the battery but neither unit will make it work. I "re-set", according to the manual but that didn't help. Any ideas or suggestions why it might not work? Thanks.
  6. B

    2004 Deville

    My 2004 Deville's "Traction Control" light comes on at different intervals, by itself. Once on, it stays on until the ignition is turned off and the car restarted. It started doing this in wet weather but now in dry weather. Anyone else ever have this problem and what was the solution? Thanks in...
  7. B

    2004 DEVILLE outside temp. gage

    My "outside air" temperature gage, located in the center part of the dash, shows "140 degrees" all the time. The AC/Heat control works perfectly. Is there a sensor for outside air temp that can be replaced? Where would it be located? I would appreciate any information.
  8. B

    Mark VII Speedometer

    I have a 1989 Mark VII with 63,000 original miles. The car sits for 9 months in a garage with a dehumidifier running. I now find that the speedometer shows "0" for about the first 10 minutes of driving. Then it comes on and works and the odometer also starts working. During this "warm up"...
  9. B

    Mark VII speedometer

    This is my first time to ask a question so here goes. I have an '89 Mark VII with 63,000 original miles. It now takes about 10 minutes of driving before the speedometer starts to read. During the 10 minute perion, the fuel gage also "floats" around (within a few gallons of what is actually in...
Top