What did you do to your Mark VIII today?

Dr.Mark

Active LVC Member
Joined
May 4, 2015
Messages
54
Reaction score
10
Location
Sidney
She got a tune up today with new plugs, air and fuel filters, and a fresh oil/filter change. I see that I need new valve cover gaskets so I have a set coming. While I have the covers off I'm going to strip the front of the motor down and clean/paint everything I can and just do a makeover under the hood. It's pretty clean but will look 10X better

IMG_20170604_122506.jpg
 

driller

Dedicated LVC Member
Joined
Mar 21, 2004
Messages
3,795
Reaction score
77
Location
West Virginia
That looks good Driller what's under the hood and what's she run?

Boss 5.0L Modular block, stroked to 5.3L, Kellogg crank, Manley rods, Gibtec pistons, Fox Lake "B" heads w/ PAC Racing valve train, Hogans intake, Canton 8 qt. oilpan, 12.6 CR, naturally aspirated.

Best ET 12.68 @ 109 (so far).
 
Last edited:

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
0818171828a.jpg
Hey everyone. I'm a newbie, just acquired a '97 VIII blk/blk. So. Cali desert car, 2nd owner, garage kept, 90k miles. Upgraded audio to Kenwood touch screen, tinted windows, flushed engine, power steering, brake fluid, rear dif, and tranny and replaced all with Amsoil synthetics. Have Stop Tec front and rear perf and slotted rotors with Hawk pads on the way. R&r'd the chrome accent strips on the bottom of the doors and front of rear wheels.
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
View attachment 828566816 Hey everyone. I'm a newbie, just acquired a '97 VIII blk/blk. So. Cali desert car, 2nd owner, garage kept, 90k miles. Upgraded audio to Kenwood touch screen, tinted windows, flushed engine, power steering, brake fluid, rear dif, and tranny and replaced all with Amsoil synthetics. Have Stop Tec front and rear perf and s
Very nice
And I see the wheels are on correctly nice

lotted rotors with Hawk pads on the way. R&r'd the chrome accent strips on the bottom of the doors and front of rear wheels.

Thank you, slowmkvii. One big problem is the washer switch at the end of the washer and turn arm is missing, and been all over the galaxy looking for one, but have been unsuccessful. Any ideas?
 

slowmkviii

Dedicated LVC Member
Joined
Sep 28, 2007
Messages
5,677
Reaction score
161
Location
Elk River, MN
there a couple of members on here who sell them
so post in wtb parts and wait
or go to the facebook site and ask
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
Thanks slowmkvii. Found on eBay from racebronco2. Button and spring. Hopefully I'll figure out how to install it properly. :)
 

slowmkviii

Dedicated LVC Member
Joined
Sep 28, 2007
Messages
5,677
Reaction score
161
Location
Elk River, MN
EATC code 155: SCP invalid or missing data for displays (caused by MC)

030 Self test indicates automatic temperature control sensor shorted
Fix 30 and 155 will probably go away
Also possible blend door arm or actuator
Depending on the year
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
My '97 has a serious condensation problem in the left headlamp but couldn't find any videos or other instruction on how to remove it to clear and reseal it, been looking all day. Any help is appreciated. It looks relatively easy by just removing the retaining screw at the rear of the assembly. What else do I need to do?
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
YEEEEAAAHH!! I just now got a windshield wiper button-switch for my '97 from racebronco2, installed it, and it WORKS. I now have an operating windshield washer! What a relief! It's the little things in life that can be so great.

Car1.jpg
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
What DIDN'T I do to my Mark? Flew to Burbank CA fro Dallas, TX. Picked it up in California from 2nd owner--all records. Desert car and garage-kept, absolutely no rust anywhere. Drove back to Dallas for:
1)window tint
2)Upgraded to Kenwood Touchscreen Sirrius radio

From Dallas drove to Jacksonville, FL, then Miami. From Miami took it to The Magic Mechanic in Orlando where I:

3) I had all fluids flushed -- oil, tranny, p-steering, brake lines, rear differential and replaced all with Amsoil synthetics.

From there drove it to CT where I:
4) R&R'd fr and rr rotors and replaced with Stop Tech racing rotors with Hawk pads
5) R&R'd tensioner, pully and serpentine belt
6) Located and installed washer button -- and it WORKS!
7) Today had front suspension -- ball joints, bushings and sway bar end links replaced with MOOG problem solvers -- HUGE difference in ride and handling (of course).

Friday to detail shop for complete polish and ultimate detail job.

Next week having the heater assembly replaced -- the box was busted so replacing the actuator would not have made any difference.

And then . . . . I'm f*(&#$g done for the time being.

I don't have a girlfriend, I have a very, VERY demanding and expensive mistress.

Car1.jpg


Car2.jpg
 

BlackCloud

LVC Member
Joined
Oct 2, 2017
Messages
14
Reaction score
0
Location
Louisville
After sitting for 5 years (yeah, i know... I probably can't afford this car, but have had it for 12 years) because I couldn't afford to fix the air ride, we had to move. Got a new battery, 5 gallons of gas, a can of Sea Foam, and she started right up. Amazing!
 

germansheperd

Active LVC Member
Joined
Jun 1, 2016
Messages
161
Reaction score
28
Location
Wooster, Ohio
What DIDN'T I do to my Mark? Flew to Burbank CA fro Dallas, TX. Picked it up in California from 2nd owner--all records. Desert car and garage-kept, absolutely no rust anywhere. Drove back to Dallas for:
1)window tint
2)Upgraded to Kenwood Touchscreen Sirrius radio

From Dallas drove to Jacksonville, FL, then Miami. From Miami took it to The Magic Mechanic in Orlando where I:

3) I had all fluids flushed -- oil, tranny, p-steering, brake lines, rear differential and replaced all with Amsoil synthetics.

From there drove it to CT where I:
4) R&R'd fr and rr rotors and replaced with Stop Tech racing rotors with Hawk pads
5) R&R'd tensioner, pully and serpentine belt
6) Located and installed washer button -- and it WORKS!
7) Today had front suspension -- ball joints, bushings and sway bar end links replaced with MOOG problem solvers -- HUGE difference in ride and handling (of course).

Friday to detail shop for complete polish and ultimate detail job.

Next week having the heater assembly replaced -- the box was busted so replacing the actuator would not have made any difference.

And then . . . . I'm f*(&#$g done for the time being.

I don't have a girlfriend, I have a very, VERY demanding and expensive mistress.

View attachment 828566982

View attachment 828566983
Car looks real nice!
 

Jim Knight

Active LVC Member
Joined
Aug 18, 2017
Messages
88
Reaction score
12
Location
North Haven, CT
Had the beast buffed, fully detailed, and finalized with the new ceramic coating. Prestige Auot Detail in Salt Lake City did an incredibly awesome job!!

1120171715.jpg


1120171715b.jpg


1120171715a.jpg
 

Jaye-One

LVC Member
Joined
Dec 8, 2017
Messages
19
Reaction score
0
Location
Dayton Ohio
Pulled her out the garage after tuning her up this weekend. Warmed her up and prayed the door would not do the I'm froze and I don't wanna close trick! Success it shut and we did a 17 mile stretch at 90 mph on the way to work. SHE DID AWESOME! :cool:
 

fordknutt

LVC Member
Joined
Nov 13, 2013
Messages
39
Reaction score
3
Location
Maize
Had to do same thing last week, except mine was worse as the oil pressure sender bung was cracked. Could not locate a replacement oil filter adapter locally, so had a shop (Cylinder Head Repair - Wichita KS) cut off damaged portion & weld on some aluminum stock, drilled & tapped for new oil pressure sender. While I was getting it repaired, found an adapter @ salvage yard & purchased it just in case. Installed repaired unit. No leaks!

20180117_150538.jpg


20180117_150538.jpg


20180117_150600.jpg
 

Dougviii

Active LVC Member
Joined
Feb 5, 2018
Messages
77
Reaction score
1
Location
Montgomery Tx
Monday & Tuesday fixed the air ride, still a little stiffer then I want but it's filling, venting, sitting lower & level ! Wednesday I installed new drivers side powerwindow motor (new complete seamans vdo motor from rockauto for $18 + S&H, what a deal !) Yesterday I just dtove it ! Today it's getting bath
 

Members online

Top