tailight issue

ruffsmkviiib

LVC Member
Joined
Jan 8, 2008
Messages
32
Reaction score
0
Location
ventura
hi guys,was wondering if anybody could shed some light on a problem i have with no tailights.all of a sudden i have no tailights or parking lights.will a faulty rear neon ballast cause this?i was changing the neon ballast with another to see if it worked and then no tailights.any info would help thanx carl
 

Scallywag

Well-Known LVC Member
Joined
Oct 4, 2010
Messages
219
Reaction score
11
Location
Franklin Park
Can you put the car into gear at all? If not, then might just be a fuse that got burnt out.

I had something similar happen to me once where I had noticed the ballast was disconnected from the harness, so I connected it and turned on the car only to see smoke coming out of the trunk.

Yikes!! Bad idea!!

So I disconnected the ballast from the harness and was going to go about my merry way when I noticed the brake being super stiff and I couldn't put the car into gear. Sure enough, connecting the bad ballast had shorted the brake fuse, don't know how, but it did, and so I just replaced the fuse and everything was a ok.

Lets hope that's all it is.
 

philly0420

Dedicated LVC Member
Joined
May 18, 2010
Messages
1,943
Reaction score
2
Location
Where stalkers run rampant
I had a short behind the dash that did the same thing. Except I was able to put the car in gear and drive just had no parking lights, dash lights, or tail lights
 

Members online

No members online now.
Top