no cabin heat! deville concours

iamproctor

New LVC Member
Joined
Dec 19, 2014
Messages
6
Reaction score
0
Location
guelph ontario
Hey guys! I'm new to the forums! I have a 97 deville concourse with about 276,000 on it. I recently started driving it again here in Canada and none of my fan speeds are working at all! I can hear the door inside working when you change settings but there is no fan blower power. Any ideas where I can start with this? Its -11 out and its freezing driving my car!

Any help is much appreciated!

Thanks Mike!
 

dfoy50

Active LVC Member
Joined
Oct 26, 2014
Messages
78
Reaction score
0
Location
fort myers fl.
first off check all of your fuses . second check the blower motor make sure that it turns freely . and i dont mean to sound like a broken record here but www.bbbind.com has free wiring diags. on line that could help trouble shooting . it looks like there are a few modules in the circuit , i would sart by looking for 12 volts on the c terminal on the blower motor if you dont get it there look for a fuse or broken wire if you have 12 volts there check for a good ground at terminal a on the blower motor . this can be checked with a vom or by using a jump wire from term a to the negative battery term if you have a good ground check for a signal voltage on terminal b from the heater and ac control programmer. it appears that the blower motor has the blower speed control built in to it if you have 12 volts and a good gnd and the control signal i'd say bad blower motor , if you get no speed signal voltage on b then you need to look heater and a/c programer

best of luck
 

proctor

Active LVC Member
Joined
Feb 22, 2014
Messages
57
Reaction score
0
Now where are the fuses for the blower located on this car? Also what tools will I need to get blower out? And where is it located? I'm planning on going to a wreckers this week as I'm freezing driving my car!
 

iamproctor

New LVC Member
Joined
Dec 19, 2014
Messages
6
Reaction score
0
Location
guelph ontario
Ok! I did the fuses and relays no luck. Looks like I'm doing the blower motor Tuesday.
Also need to do a lower rad hose due to leaking at. The bottom clamp
 

Members online

Top