loud clicking noise in my 97 Town Car??? what is it??

SouthCrackalack

New LVC Member
Joined
Dec 1, 2004
Messages
9
Reaction score
0
Location
South Carolina
Hi everyone..great site..I am new here and liked the idea so thought I would join. 97' Town Car owner here. I recently purchased the car..and love it. This morning after starting my car and turning on the floor heat..I noticed their was a pretty loud clicking noise coming from behind the thermostat controls or under the radio. It is a rather loud repetitive clicking/popping noise(every 2-3 seconds). im pretty sure it must be some sort of mechanism making the noise since it is clicks/pops on a continious cycle(not random,etc. I have no clue to what it could be. After lightly banging on my panels,etc and pressing different buttons on my thermostat,it stopped. I have no clue to what this could have been..and figure this would be a good starting point to try to find out. It was a bit cold this morning..so I dont know if that might have something to do with it. Just thought I would introduce myself..and present my first question. thanks for your time!

heath
 
H

HizHonor

Guest
Welcome! :W It sounds as if you might be in for a Blend Door problem. It sounds like the actuator is going south on you. Actually it's a pretty common occurance on Lincolns. Go here:
http://www.lincolnsonline.com/article20.html

It'll give you an idea of what you might be in for. Sorry to be the bearer of bad news! ;( Good luck!


SouthCrackalack said:
Hi everyone..great site..I am new here and liked the idea so thought I would join. 97' Town Car owner here. I recently purchased the car..and love it. This morning after starting my car and turning on the floor heat..I noticed their was a pretty loud clicking noise coming from behind the thermostat controls or under the radio. It is a rather loud repetitive clicking/popping noise(every 2-3 seconds). im pretty sure it must be some sort of mechanism making the noise since it is clicks/pops on a continious cycle(not random,etc. I have no clue to what it could be. After lightly banging on my panels,etc and pressing different buttons on my thermostat,it stopped. I have no clue to what this could have been..and figure this would be a good starting point to try to find out. It was a bit cold this morning..so I dont know if that might have something to do with it. Just thought I would introduce myself..and present my first question. thanks for your time!

heath
 

SouthCrackalack

New LVC Member
Joined
Dec 1, 2004
Messages
9
Reaction score
0
Location
South Carolina
HizHonor said:
Welcome! :W It sounds as if you might be in for a Blend Door problem. It sounds like the actuator is going south on you. Actually it's a pretty common occurance on Lincolns. Go here:
http://www.lincolnsonline.com/article20.html

It'll give you an idea of what you might be in for. Sorry to be the bearer of bad news! ;( Good luck!

hmm..not exactly what I wanted to hear..but I do appreciate your help. I did a little research and it does in fact sound like that could be the problem. Anyone know how much this might run to get replaced at a shop? The last thing I want is to get ripped off. thanks for your help!
 

SouthCrackalack

New LVC Member
Joined
Dec 1, 2004
Messages
9
Reaction score
0
Location
South Carolina
another quick question: from what I have read..it seems that the heat goes out if the blend door actuator goes bad. My heat works perfectly fine. Is their a possibility it is something else...or is it possible for it to need replacing and the heat still actually work fine?

I just read on the net that a new blend door actuator costs about $30 but the labor costs about $600-900!!! I HOPE this is not true..because I can't afford that at all right now. HELP!!!
 
H

HizHonor

Guest
There's others that might have an idea what it could be.. might be something as simple as a relay. <shrug> That's why I gave you that link. You can do the job with a bit of help. It's just tedious and time consuming. Sorry I can't be of any more help.



SouthCrackalack said:
another quick question: from what I have read..it seems that the heat goes out if the blend door actuator goes bad. My heat works perfectly fine. Is their a possibility it is something else...or is it possible for it to need replacing and the heat still actually work fine?

I just read on the net that a new blend door actuator costs about $30 but the labor costs about $600-900!!! I HOPE this is not true..because I can't afford that at all right now. HELP!!!
 

SouthCrackalack

New LVC Member
Joined
Dec 1, 2004
Messages
9
Reaction score
0
Location
South Carolina
HizHonor said:
There's others that might have an idea what it could be.. might be something as simple as a relay. <shrug> That's why I gave you that link. You can do the job with a bit of help. It's just tedious and time consuming. Sorry I can't be of any more help.

thanks for that link. If I can find a garage to use,I will put that link to use and see if I can figure it out. thanks again.
 

Lizzy the Lincoln

LVC Member
Joined
May 20, 2014
Messages
12
Reaction score
0
Location
Philadelphi
I have the same problem. I just bought a 97 town car and it makes a constant clicking noise that sounds like it's coming from the dash. The A/C does not blow cold either and when I turn the ac or vent on the clicking gets faster. Any ideas? That link no longer works. Thanks
 

cornerway

LVC Member
Joined
May 7, 2014
Messages
19
Reaction score
1
Location
USA
The clicking noise may be coming for the relay. Ignition/ starter relay.
 

Buzz Buzard

New LVC Member
Joined
Aug 9, 2016
Messages
1
Reaction score
0
Location
Jacksonville
Under drivers dash fuze box Unplug 15a Fuze # 1 turn on key see if clicking goes away Plug Fuze back in if clicking stops run self test If it comes back removed fuze and install a 5/8 shut off valve in the upper heater hose turn it off to have AC on for Heat not great but is a cheap fix. will work on 95 to 97 Lin TC
 

Members online

No members online now.
Top