Cooling fans

foxpaws

Dedicated LVC Member
Joined
Sep 8, 2008
Messages
3,971
Reaction score
0
Location
Denver
Well, I might not get any answers - but, just in case the normal sources come up empty... And you never know where a N* mechanic might lurk....

So, I was in a big butt Eldo recently, a N*, and I could really hear the cooling fans, and they even remained on after the car was shut off...

Amante - nothing. I have never heard the fans - and never has anything been running after the engine was shut down.

It isn't like he hasn't been driven in hot weather - 100 degrees - in traffic... the temperature bars have gone up to 1 above normal (for a minute or two, then back down to normal), but that is it. Never overheated, or anything, and never any fan noise.

But, I am beginning to wonder if the fans aren't working. Is there a way to test for this - and since I bet there is something wrong - probably a relay - right? Hard to replace - or do you need to be an Italian mechanic to do it correctly?

Ran codes on the DIC and nothing there either...

Thanks....
 

brentalan

Dedicated LVC Member
Joined
Nov 15, 2004
Messages
1,824
Reaction score
16
Location
Alpha, NJ
take the car for a ride, get it up to temperature and then park somewhere and let it run. The fans should come on after a few minutes (I'd wait a good 15 minutes to be sure) because there is no cooling to the radiator. If they don't, the alternative is the temp gauge will start rising.
 

BAD97LSC

Dedicated LVC Member
Joined
Nov 15, 2006
Messages
9,541
Reaction score
10
Location
Palm Harbor FL
exactly, turning the a/c to max air will make the cooling fan come on even if the car is cold.
 

foxpaws

Dedicated LVC Member
Joined
Sep 8, 2008
Messages
3,971
Reaction score
0
Location
Denver
Thanks guys, they are spinning up a storm, I did the A/C test - however they are the most quiet fans I have ever 'not heard'... I put my hand in front of the radiator and I can really feel the air being pushed through.

Well - at least this summer if I decide a cross midwest trip is in the stars - the old boy should be happy... and cool...
 

cornerway

LVC Member
Joined
May 7, 2014
Messages
19
Reaction score
1
Location
USA
It could be busted thermos-witch sensor that is why its not working automatically.
 

Members online

Top