2000 LS Aftermarket radio install

Car Audio & Car Electronic

  1. joegarv

    joegarv New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 15, 2011
    Location:
    Cleveland
    Looking for some help/opinions...

    Installed a Sony DSX-S200X receiver into my 2000 Lincoln LS a couple months ago. Along with receiver I purchased a steering wheel radio control adapter and all the Sirius components. Everything was working fine for about a month then mysteriously my car would not start. Battery tested good. Alternator was good. I'm assuming something from my new setup is drawing on the battery.

    Crutchfield tech support was unable to point me in the right direction. 12v constant wires should obviously not be drawing a battery down. I'm not exactly an electrical whiz but know enough basics.

    Anyone have any ideas? Help would be much appreciated!

    Thanks.
     
  2. kaball

    kaball Well-Known LVC Member

    Messages:
    389
    Likes Received:
    1
    Joined:
    Oct 19, 2011
    Location:
    Daytona Beach
    almost sounds like a short. if your battery tested good then you shouldn't be having a drain. I have a DSX-S100 and have never had a problem.

    have you tried to unplug the radio head and start?
     
  3. joegarv

    joegarv New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 15, 2011
    Location:
    Cleveland
    Ya. It wouldn't start again this morning. Got a jump. Once I arrived at work I unplugged radio. Went to start the car at lunch- no problem.
     
  4. kaball

    kaball Well-Known LVC Member

    Messages:
    389
    Likes Received:
    1
    Joined:
    Oct 19, 2011
    Location:
    Daytona Beach
    did you use an adapter or did you solder it into the existing harness?
     
  5. joegarv

    joegarv New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 15, 2011
    Location:
    Cleveland
    I used an adapter that Crutchfield included.
     
  6. kaball

    kaball Well-Known LVC Member

    Messages:
    389
    Likes Received:
    1
    Joined:
    Oct 19, 2011
    Location:
    Daytona Beach
    I know when I installed mine I bought the two piece adapter from pepboys and I dont have any problem at all. Is the S200 the one with the bluetooth in it? are you leaving your ipod or usb device plugged in?
     
  7. joegarv

    joegarv New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 15, 2011
    Location:
    Cleveland
    I don't believe it has blue-tooth. I disconnect my ipod every time I turn the car off.
     
  8. joegarv

    joegarv New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Nov 15, 2011
    Location:
    Cleveland
    Don't think it has Blue Tooth. I unplug my ipod whenever I turn the car off.
     

Share This Page