1990 Lincoln Towncar

Lincoln Town Car

  1. 582Boat

    582Boat Active LVC Member

    Messages:
    55
    Likes Received:
    0
    Joined:
    Jun 24, 2005
    Location:
    Battle Creek, MI
    I own a 1990 Lincoln t/c that has been in Florida since new, probably never really used the heating system, not I am in Michigan and do need heat. I find that it is blowing cool air when I have turn the lever over to heat, does not throw any heat. Do I have a climate control problem or do you think it is a valve not opening up and allowing hot water to pass through the heater. Need help.
     
  2. TownCar

    TownCar Active LVC Member

    Messages:
    127
    Likes Received:
    0
    Joined:
    Apr 10, 2004
    Location:
    Near Los Angeles
    Check the other 'modes' as well;
    • Vent
    • Defrost
    • Hi-Lo
    After the engine is fully warmed up. Report back ----
     
  3. dragon88TC

    dragon88TC New LVC Member

    Messages:
    5
    Likes Received:
    0
    Joined:
    Aug 20, 2006
    Location:
    Philadelphia
    I have an 88 and when i first tried to use the heat it did the same thing as you described. i did some research in the net and found that if you open the glove box, look on the left hand side in the back there is a vacume line going into a round gold "thingy" pull the line off it and plug the line with something, your heat will work just fine.....but then you wont have any air condition..lol, just plug it back itto the "thingy" again for your air to work.
     
  4. Pepsi2185

    Pepsi2185 LVC Mafia Henchman

    Messages:
    609
    Likes Received:
    1
    Joined:
    Mar 30, 2004
    that is the blender door. did you ever get a chance to check those modes? Also listen for vacuum leaks. The 90 is in the transition years from vacuum to electrical.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.